Cannot create blob store

When creating s3 repositories or trying to query snapshots for an existing repository I get SQLActionException[RepositoryException: [local_restore] cannot create blob store]
I’m not sure if this is a bug, but is there some way of fixing it?
Running a single node, crate 3.2.2.

1 Like

I’ve worked this out - my crate config didn’t have my s3 details in.

1 Like

We encountered the same issue. Can you explain how to resolve this issue?

@nocturnaltortoise any chance you could help @Lynxeyed out on this?

Pretty sure the cause of my issue was that I didn’t have the s3 access key and secret key in my crate config, but my crate repository was set up as if I did have them in the config.

We are having same issue. any work around ?

I tried following but not worked

create repository test123 type s3 with (bucket='test123', endpoint='', protocol='https', access_key='...',secret_key='...',base_path='test123');

@nocturnaltortoise did you solved this issue ?

I got same error There was two possibility i observed

  1. I used default endpoint
  2. I have created predefined bucket in aws (permission issue) and issue got resolved