Upgrade from 4.2.6 to >= 4.3.0 problem


We are trying to upgrade from Crate 4.2.6 to a newer version, for example 4.3.4, and keep getting errors regarding the tables: “unable to upgrade the mappings”.
This seems to affect tables that were created on Crate < 4.0 so we tried recreating them, but encountered the COPY circuit breaking exception bug (fixed in 4.3.1).
What options do we have to upgrade ?

Hi @rps-v

What does the following query return

SELECT table_name, version['upgraded'], version['created']
FROM information_schema.tables
WHERE table_schema NOT IN ('information_schema','pg_catalog','sys')

Do you still have tables created before v3.x ?

The oldest tables were created on Crate v3.2.

Hi @rps-v,

when re-creating the table I suppose you tried both COPY TO and INSERT FROM QUERY? Do both run into the circuit breaker issue?

Maybe it would be an option to circumvent this issue by splitting the data copy process into multiple smaller copy commands. For example for a partitioned table to move one partition after another.

Can you give this approach a try?

Only tried INSERT FROM QUERY so far and it seems that the circuit breaker exception is intermittent as the second time I ran the same query it worked fine.
Will try COPY TO if it still fails somehow and keep you updated with the progress.
Thanks for the suggestions !

1 Like

Did it work out in the end?

We tested this on our smaller cluster and it worked using COPY TO. Haven’t gotten around to migrating the big cluster yet though… will keep you updated as soon as that happens.

1 Like