How to set Limit of total fields [1000] in index

I am getting the below mentioned error,

   "error" => %{
     "code" => 4000,
     "message" => "SQLParseException[Limit of total fields [1000] in index [.partitioned.test_table.04732dhm6gqjgchk60o30c1g] has been exceeded]"

So, I wanted to know is there a way to increase the limit ?

or is there any other solution for the same.

Thanks in advance.


the limit is configurable through the mapping.total_fields.limit setting as part of CREATE TABLE (or ALTER TABLE).


CREATE TABLE t1 (a INTEGER) WITH ("mapping.total_fields.limit" = 2000);
ALTER TABLE t1 SET ("mapping.total_fields.limit" = 2000);

Please monitor the performance of your queries carefully when increasing limits. If you increase limits drastically, there might (at some point) be an impact on performance due to internal data structures/overhead.

ohh ok got it @hammerhead and thanks for the solution.